Funktionen: DATEDIF, GANZZAHL, RUNDEN, REST

Geburtstag: Anzahl der Jahre, Monate und Tage korrekt berechnen

Funktionen: DATEDIF, GANZZAHL, RUNDEN, REST.
Geburtstag: Anzahl der Jahre, Monate und Tage korrekt berechnen
A B C D E
30.03.1966 Tage Jahre Monate Tage Formeln mit RUNDEN, GANZZAHL und REST
16.237 44 5 14 =SUMME(RUNDEN(HEUTE()-A1;0))
=GANZZAHL(B2/365,2425)
Diese Formeln ergeben falsche Werte, da die Schaltjahre =GANZZAHL(REST(B2;365,2425)/30,436875)
mit Hilfswerten berechnet werden müssen. =GANZZAHL(REST(REST(B2;365,2425);30,436875))
           
Jahre Monate Tage Formeln mit DATEDIF und Schaltjahr-Hilfswerten
44 5 14 =DATEDIF(A1;HEUTE();"y")
=DATEDIF(A1;HEUTE();"m")-12*C1
Diese Formel ergibt falsche Werte, da das Schaltjahr =DATEDIF(A1;HEUTE();"d")-(365,2425*C1)-D1*30,436875
mit einem Hilfswert berechnet werden muss.
           
Jahre Monate Tage Korrekte Formeln mit DATEDIF-Parametern
44 5 13 =DATEDIF(A1;HEUTE();"y")
=DATEDIF(A1;HEUTE();"ym")
=DATEDIF(A1;HEUTE();"md")
DATEDIF-Parameter
y Anzahl der vollständigen Jahre im definierten Zeitraum.
m Anzahl der vollständigen Monate im Zeitraum.
d Anzahl der vollständigen Tage im Zeitraum.
md Differenz zwischen den Tagen in Anfangs- und Enddatum. Monate und Jahre werden ignoriert !
ym Differenz zwischen Monaten in Anfangs- und Enddatum. Tage und Jahre werden ignoriert !
yd Differenz zwischen Tagen in Anfangs- und Enddatum. Die Jahre der Datumsangaben werden ignoriert !

Mehr Tipps: Excel - Formeln teilweise berechnen

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt