Tabellenfunktionen in Excel

Tabellenfunktionen in Excel: Indizierungs-, Zusammenfassungs- und Verweiswerte; Teilsummen-Formeln
Anzeige von Fehlerwerten vermeiden
Tabellenfunktionen liefern Fehlerwerte (#DIV/0!, #N/V, #WERT!, #BEZUG! und #ZAHL!), wenn diese
auf unerwarteten Werten beruhen.
Beispiel: eine einfache Divisionsformel. Enthält eine Zelle einen Nullwert, wird der Fehlerwert #DIV/0!
im folgenden Beispiel zurückgegeben.
Zelle A12 Zelle B12 Original-Formel Neue Formel
25 0 #DIV/0!
=A12/B12 =WENN(B12=0;" ";A12/B12) ...Notlösung...
=WENN(ISTFEHLER(A12/B12);"";A12/B12)
Das Standardformat für diese Formel ist:
=WENN(ISTFEHLER(<Formel>);" ";<Formel>)
wobei <Formel> die Formel ist, für die Sie den Fehlerwert unterdrücken möchten. Sofern <Formel>
einen Fehlerwert zurückliefert, liefert diese Aussage " " (leere Zeichenfolge), andernfalls wird das
Resultat von <Formel> geliefert.
Excel bietet eine weitere Möglichkeit über 'Bedingte Formatierung' die Anzeige von Fehlerwerten zu
unterdrücken. Bedingte Formatierung gibt die Möglichkeit, in einer Zelle verschiedene Formate, in
Abhängigkeit von dem Zelleninhalt, anzuzeigen. Für Fehlerwerte, verfährt man wie folgt:
1. Wählen Sie eine zu formatierende Zelle aus (in diesem Beispiel $D$35).
2. Klicken Sie auf 'Format', 'Bedingte Formatierung...' auf der Menüleiste.
3. In der ersten Dropdown-Liste wählen Sie "Formel Ist"
4. Im nächstliegenden Bearbeitungsfeld geben Sie den Text =ISTFEHLER($D$35) ein.
5. Klicken Sie die Schaltfläche Format. Für dieses Beispiel wurde unter 'Muster' ein blauer
Zellenhintergrund und als 'Schrift' die Farbe Blau gewählt.
6. Klicken Sie OK.
Das Resultat ist, daß bei Fehlerwerten die Schriftfarbe der Hintergrundfarbe entspricht und somit
nichts sichtbar ist:
Zelle C12 Zelle D12 Original Format Neues Format mit 'Bedingter Formatierung'
25 0 #DIV/0! #DIV/0! =ISTFEHLER($B$35)
=A35/B35 =A35/B35
Indizierungs-, Zusammenfassungs- und Verweiswerte
Eine der am häufigsten vorkommenden Aufgaben in der Anwendung von Tabellenblättern ist das Finden
eines Wertes, der auf dem Schnittpunkt einer bestimmten Spalte und Zeile liegt. Der Verweis-
Assistent unterstützt Sie bei diesem Vorgang mit der Erstellung einer Formel, um bestimmte
Informationen, basierend auf Zeilen- und Spaltenbeschriftungen, zu finden.
Um diese Eigenschaft zu nutzen, wählen Sie eine Zelle innerhalb des Datenbereichs aus.
Von der Menüleiste wählen Sie 'Extras', 'Assistenten', 'Verweis'.
Teilsummen-Formeln
Eine weitere häufig auftretende Aufgabe ist die Summierung von Werten, die bestimmte Konditionen
erfüllen. Der Teilsummen-Assistent hilft bei der Erstellung von Formeln, um diese Aufgabe
zu erfüllen.
Um diese Funktion anzuwenden, wählt man eine Zelle im Tabellenblatt aus. Von der Menüleiste
wählt man 'Extras', 'Assistenten', 'Teilsummen-Assistent'.
.

Mehr Tipps: Excel - Dateien eines bestimmten Dateityps schneller öffnen

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt