Excel - In Arbeitszeiterfassung Nachtschichten berechnen

In Arbeitszeiterfassung Nachtschichten berechnen

Möchte man mit Excel Nachtschichten berechnen, bietet es sich an, spaltenweise die Sollstunden, den Arbeitsbeginn, das Ende, die Summe und die Über- oder Unterstunden zu erfassen. Allerdings gerät man in eine Falle, wenn man in der Summe der Stunden die einfache Formel "Arbeitsende minus Arbeitsanfang minus Pausen" verwendet. Sobald man versucht, Nachtschichten zu berechnen, die an einem Tag beginnen und am nächsten Tag enden, erhält man im Summenfeld Minuswerte.

Um das zu verhindern, kann man im Summenfeld statt der einfachen Subtraktion eine Wenn-Abfrage verwenden. Sie überprüft, ob der Wert in der Spalte Arbeitsende kleiner ist als der in der Spalte Arbeitsbeginn, und addiert in diesem Fall einen Tag dazu.

Möchten Sie also im Feld F2 die Summe der Arbeitsstunden ermitteln, verwenden Sie die Formel =WENN(C2>D2;D2+1-C2-E2;D2-C2-E2). Dann addiert Excel einen Tag, also 24 Stunden, falls das Arbeitsende auf den nächsten Tag fällt. Fallen Arbeitsbeginn und Arbeitsende auf denselben Tag, werden die Werte in den Spalten C und E von denen in Spalte D abgezogen.

Beachten Sie jedoch, dass Sie bei Arbeitszeitberechnungen die Option 1904-Datumswerte in Extras - Optionen - Berechnen aktivieren müssen, damit Excel mit eventuellen Minuszeiten in der Spalte G klarkommt. Um die Summen korrekt darzustellen, verwenden Sie in den Summenfeldern außerdem mit Format - Zellen - Zahlen die Kategorie Benutzerdefiniert und das Format [h]:mm. Andernfalls zeigt Excel keine Stundenwerte über 24 an, sondern beginnt wieder mit einer Eins, wenn die Summe mehr als 24 ergibt.

Mehr Tipps: Bedingte Formatierung

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt