Excel - Lottozahlen per Zufallsgenerator

Lottozahlen per Zufallsgenerator

Woche für Woche grübeln Millionen von Lottospielern darüber, welche Zahlen sie auf dem Schein ankreuzen sollen. Mit Hilfe der Funktion Zufallszahl und einigen Formeln nimmt Ihnen Excel diese Arbeit ab.

Um sechs Zufallszahlen zu erzeugen, schreiben Sie in die Zelle A4 die Formel: = AUFRUNDEN ( 49 * ZUFALLSZAHL();0). Danach kopieren Sie diese Zelle nach unten, bis die sechs Zellen A4 bis einschließlich A9 mit dieser Formel versehen sind.

Allerdings ist es möglich, dass Excel zweimal dieselbe Zufallszahl ausspuckt. Um das zu verhindern und außerdem das Ankreuzen zu erleichtern, müssen die Zahlen sortiert werden. Die Formeln für die Zellen B4 bis B9 stehen unten auf dieser Seite; sie sortieren die Zahlen im Bereich A4 bis A9 in aufsteigender Reihenfolge. Wenn im Bereich von B5 bis B9 zweimal die gleiche Zahl erscheinen würde, addieren die Formeln beim Duplikat automatisch die Ziffer 1.

Falls der sehr unwahrscheinliche Fall eintreten sollte, dass in den Zufallszahlen zweimal die Zahl 49 auftaucht, würde in der Zelle B9 durch die Addition der 1 die Zahl 50 erscheinen. Um das zu verhindern, ohne die Formeln unnötig zu komplizieren, sollten Sie außerdem in der Zelle B10 darauf hinweisen, dass das Ergebnis ungültig ist. Schreiben Sie deshalb in diese Zelle die Formel =WENN(B9>49;"Ergebnis ungültig! Nochmal berechnen!";"").

Falls Sie nicht 6 aus 49, sondern 6 aus 45 spielen, müssen Sie die Formeln in den Zellen A4 bis A9 und in B10 entsprechend auf 45 korrigieren. Wenn Sie Ihren Lottoschein ausfüllen wollen, betätigen Sie jedesmal die Taste [F9], nachdem Sie ein Kästchen ausgefüllt haben. Excel berechnet die Zufallszahlen erneut, und Sie können sich dem nächsten Feld des Lottoscheins widmen.

Formeln zum Sortieren der Zufallszahlen:

B4:  =KKLEINSTE(A4:A9;1)

B5:  =WENN(KKLEINSTE(A$4:A$9;2)<=B4;B4+1; KKLEINSTE(A$4:A$9;2))

B6:  =WENN(KKLEINSTE(A$4:A$9;3)<=B5;B5+1; KKLEINSTE(A$4:A$9;3))

B7:  =WENN(KKLEINSTE(A$4:A$9;4)<=B6;B6+1; KKLEINSTE(A$4:A$9;4))

B8:  =WENN(KKLEINSTE(A$4:A$9;5)<=B7;B7+1; KKLEINSTE(A$4:A$9;5))

B9:  =WENN(KKLEINSTE(A$4:A$9;6)<=B8;B8+1; KKLEINSTE(A$4:A$9;6))

Mehr Tipps: Dynamische Investitionsrechnung

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt