Excel - Flexible Berechnung von Quersummen

Flexible Berechnung von Quersummen

Um in Excel die Quersumme einer Zahl zu ermitteln, bietet sich z.B. die Funktion TEIL an. Sie ermöglicht es, den Inhalt einer Zelle in seine Bestandteile zu zerlegen und einzeln zu berechnen.

Zur Ermittlung der Quersumme isolieren Sie mit TEIL jede einzelne Ziffer der Bezugszelle, die Summe dieser Einzelziffern ergibt die Quersumme. Geht man davon aus, dass die Zahl, von der die Quersumme ermittelt werden soll, in Zelle A4 steht, lautet die Formel, um die Quersumme einer dreistelligen Zahl zu ermitteln =TEIL(A4;1;1)+TEIL(A4;2;1)+TEIL(A4;3;1). Jedoch ist diese Formel in der Anzahl der Stellen nicht flexibel. Enthält die Zelle A4 eine Zahl mit weniger Stellen, erscheint anstatt des Ergebnisses die Fehlermeldung #Wert. Enthält sie mehr Stellen, werden die hinteren Ziffern ignoriert.

Um dieses Manko auszugleichen, ist es sinnvoll, nicht die Zahl selbst, sondern das Ergebnis einer Multiplikation mit einem Vielfachen von 10 für die Quersumme heranzuziehen. Multipliziert man eine Zahl z.B. mit 1000, hat das keine Auswirkung auf die Quersumme, weil nur Nullen angehängt werden.

Möchte man z.B. aus Zahlen mit bis zu 14 Stellen die Quersumme ermitteln, muss der Multiplikator so viele Nullen an die Zahl anhängen, bis die 14 Stellen voll sind. Im Falle einer sechsstelligen Zahl müssten also 8 Nullen angehängt werden, der Multiplikator wäre demnach 100 000 000. Die Formel zur Ermittlung des Multiplikators lautet 10 hoch (14 minus Anzahl der Stellen der Zahl in A4). Also =10^(14-LÄNGE(A4)). Das Zeichen ^ finden Sie auf der Tastatur direkt links über der linken Tabulatortaste. Es erscheint allerdings erst, nachdem sie die Taste betätigt und anschließend ein Leerzeichen eingegeben haben.

Um die flexible Quersumme zu ermitteln, multiplizieren Sie nun mit der Formel =A4*B1 die Zahl in A4 mit dem Multiplikator in B1. Die Zelle mit dieser Formel verwenden Sie als Bezugszelle für die untenstehende Formel. Die WENN-Abfrage am Anfang der Formel verhindert die Fehlermeldung, falls Sie versuchen, die Quersumme von 0 zu bilden.

Formel zur Ermittlung der Quersumme für Zahlen mit maximal 14 Stellen:

=WENN(A1=0;0;TEIL(A1;1;1)+TEIL(A1;2;1)+TEIL(A1;3;1)+TEIL(A1;4;1)+TEIL(A1;5;;;;;1)++TTEIL(A1;6;1)+TEIL(A1;7;1)+
TEIL(A1;8;1)+TEIL(A1;9;1)+TEIL(A1;10;1)+TEIL((AA111;11;;1)+TEILL(A1;12;1)+TEIL(A1;13;1)+TEIL(A1;14;1))

Mehr Tipps: Optimale Bestellmenge und Lagerhaltungskostensatz ermitteln

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt