Excel - Nur Werte jeder zweiten Spalte addieren

Nur Werte jeder zweiten Spalte addieren

In Tabellen ist es häufig nötig, nur jeden zweiten oder n-ten Wert in eine Summe einzubeziehen. Dies kann man z.B. erreichen, indem man alle betroffenen Zellbezüge einzeln in die Formel aufnimmt. Die Formel könnte also =SUMME(A1+A3+A5) lauten.

Diese Methode hat jedoch Nachteile: Sie ist umständlich und vor allem bei umfangreichen Tabellen sehr zeitaufwändig. Außerdem dürfen Sie bei der Funktion Summe nur maximal 30 Argumente verwenden!

Einfacher und schneller können Sie diese Aufgabe mit dem Bezug auf einen Zellbereich statt auf einzelne Zellen lösen. Das gelingt mit einer Matrixformel. Diese Formel ist auf die Addition jeder zweiten Zelle des Zellbereichs A6 bis H6 ausgelegt:

=SUMME(WENN(REST(SPALTE(A6:H6);2)=0;A6:H6))

Wenn Sie die 2 hinter dem Semikolon durch eine 3 ersetzen, wird jede dritte Spalte in die Summe aufgenommen.

Die Funktion Spalte liefert die Spaltennummern des Bereichs. Die Spalte A hat also den Wert 1, Spalte B die 2, Spalte C die 3 und so weiter. Beachten Sie bitte, dass die Spaltennummern absolut sind. Wenn der relevante Zellbereich erst bei der Spalte D beginnt, liefert die Funktion Spalte nicht den Wert 1, sondern 4. Falls die Werte in Zeilen stehen, müssen Sie in der Formel die Funktion Spalte durch Zeile ersetzen, um die Zeilennummer zu erhalten.

Mit der Kombination der Funktionen WENN und REST werden die passenden Spalten herausgefiltert. Nur wenn die Spaltennummer geteilt durch den hinter dem Semikolon angegebenen Wert den Rest 0 liefert, also durch den Wert teilbar ist, wird Sie für die Addition verwendet.

Weil es sich bei dieser Formel um eine Matrixformel handelt, müssen Sie die Eingabe und jede spätere Änderung mit [Strg] Umschalt [Return] bestätigen.

Mehr Tipps: Excel - HTML-Tabellen erzeugen

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt