Excel - Werteanzahl und Summe je nach Auswahlkriterium

Werteanzahl und Summe je nach Auswahlkriterium

Sie haben eine Liste mit Bestellungen angelegt und möchten wissen, wie viele Bestellungen in einem bestimmten Preissegment liegen, z.B. alle Bestellungen mit einem Umfang zwischen 100 und 200 Euro. Die Lösung ist eine Arrayformel, in der Sie die Zellinhalte mit Ihrem Auswahlkriterium vergleichen und anschließend die Summe aus allen Vergleichsergebnissen bilden.

Angenommen, Sie haben verschiedene Bestellsummen im Bereich C2:C20 eingegeben. Nun wollen Sie sich in Zelle E2 anzeigen lassen, wie viele dieser Bestellungen ein Volumen zwischen 100 und 200 Euro haben. Tragen Sie in E2 folgende Formel ein:

=SUMME((C2:C20>=100)*(C2:C20<=200))

Damit die Formel als Arrayformel erkannt wird, müssen Sie sie mit der Tastenkombination Strg + Umschalt + Return abschließen. Die Eingabe ist korrekt, wenn Excel die Formel in der Bearbeitungszeile mit geschweiften Klammern {...} umgibt.

Wenn Sie wollen, können Sie die Funktionalität erweitern und in einer weiteren Zelle die Summe aller Bestellungen innerhalb eines bestimmten Wertebereichs ermitteln. Um auszurechnen, wie hoch die Summe der Bestellungen zwischen 100 und 200 Euro ist, geben Sie in Zelle E3 diese Arrayformel (!) ein:

=SUMME((C2:C20>=100)*(C2:C20<=200)*C2:C20)

Mehr Tipps: Excel - Zelleninhalt unsichtbar machen

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt