Excel - Minuszeiten richtig darstellen

Minuszeiten richtig darstellen

Möchte man in Excel Arbeitszeiten von Mitarbeitern erfassen, steht man häufig vor dem Problem, dass die Tabellenkalkulation Schwierigkeiten hat, negative Zeiten, die etwa beim Vergleich von Soll- und Istzeiten leicht anfallen können, richtig darzustellen. Versucht man einen größeren von einem kleineren Zeitwert abzuziehen, füllt Excel die Zelle mit Gittern, die sich nur durch eine Standardformatierung als Zahl, nicht aber als Zeit beseitigen lassen. Dezimalwerte sind jedoch in Zeiterfassungstabellen meist nicht erwünscht. Befriedigende Ergebnisse erhält man erst dann, wenn man diese Zahlen in eine Hilfszeile setzt.

Möchten Sie in Zeile 10 die Mehrstunden und in Zeile 11 die Minderstunden darstellen, um mit diesen Werten weiterzurechnen, verwenden Sie die Zeile 9 als Hilfszeile, die in der fertigen Tabelle ausgeblendet wird. In dieser Zeile erfolgt die Berechnung Ist- minus Soll-Stunden.

Solange dieser Wert positiv ist, hat Excel kein Problem, doch ist er negativ, kommt es zum oben beschriebenen Effekt. Mit dem Format | Zellen | Zahlen | Uhrzeit lässt sich dieser Wert nicht darstellen. Wohl aber kann er zur weiteren Berechnung herangezogen werden, dann, wenn die Funktion ABS verwendet wird. Sie entbindet eine Zahl ihres Vorzeichens, schafft also den hinderlichen negativen Wert aus der Welt.

Damit in Zeile 10 die täglichen Überstunden und in Zeile 11 die zu wenig geleisteten Stunden erscheinen, tragen Sie dort folgende Formeln ein: in Zelle B10 die Formel =WENN(B9>0;(B9);0 und in Zelle B11 =WENN(B9<0;ABS(B9);0). Kopieren Sie diese Formeln über sämtliche Spalten der Woche und formatieren Sie anschließend die Zeilen 10 und 11 mit Format | Zellen | Zahl | Uhrzeit im gewünschten Format.

Eine Besonderheit werden Sie noch in der Summenspalte feststellen: Excel ist so "intelligent", Zeiten nur bis zu 24 Stunden zu addieren und danach wieder bei 0 zu beginnen. Versuchen Sie also, eine Summe aus den 5 Arbeitstagen a 8 Stunden zu bilden, wird Excel beharrlich die Stundenzahl 16:00 ausgeben. Sie können diese, in diesem Fall unerwünschte, Eigenmächtigkeit umgehen, indem Sie diejenigen Zellen, die Zeitensummen über 24 Stunden anzeigen sollen, mit einem benutzerdefinierten Format ausgeben.

Wählen Sie dazu Format | Zellen | Zahlen | Benutzerdefiniert und geben Sie dann unter Formate die Zeichenfolge [h]:mm ein. Durch die eckigen Klammern im Zellenformat wird Excel angewiesen, Stundenwerte auch über 24 Stunden hinaus auszugeben.

Mehr Tipps: Excel - Abgelegene Zellbereiche per Kamera ins Blickfeld rücken

Sponsoren und Investoren

Sponsoren und Investoren sind jederzeit herzlich willkommen!
Wenn Sie die Information(en) auf dieser Seite interessant fanden, freuen wir uns über eine kleine Spende. Empfehlen Sie uns bitte auch in Ihren Netzwerken (z. B. Twitter, Facebook oder Google+). Herzlichen Dank!

Nach oben Sitemap
Impressum & Kontakt